скрипт_перезапуска_интерфейса_lte

Данный сценарий перезапускает интерфейс LTE в 03:00 каждый день, в этом примере соединение LTE называется «lte1»

/system scheduler add name="LTE reconnect" interval=1d start-time=03:00:00 on-event="/interface lte disable lte1 ;delay 10s; /interface lte enable lte1;"

В отличие от приведенного, выше скрипта, следующее решение обрабатывает такую логику:

  • проверить ping на 8.8.8.8 и, если будет потеряно более 20 пакетов,
  • автоматически отключает и включит Lte интерфейс.
  • в противном случае он будет запускаться каждую 1 минуту в планировщике с записью «Connection OK».
:if ( [/ping 8.8.8.8 count=10 size=64 interval=2s ] =0) do={
:log error "-----No ping";
#/system routerboard usb power-reset duration=10;
/interface lte disable lte1;delay 10s;
/interface lte enable lte1;
:log error "----Restart lte interface";
} else={
#:log info "-----LTE OK-----";
}
  • скрипт_перезапуска_интерфейса_lte.txt
  • Последнее изменение: 2021/09/23 12:07
  • admin